Liste des commandes Cisco

Les commandes utiles

Pour l’ensemble de ces commandes nous prendrons pour exemple les informations suivantes :

  • IP Routeur : 192.168.1.1 255.255.255.0
  • Vlan 10 : 192.168.10.1 255.255.255.0
  • IP Serveur DHCP : 192.168.1.2 255.255.255.0

 

Switch :

//Accéder à la configuration :
Switch>enable
Switch#conf t
//Création d’un vlan :
Switch(config)#vlan 10
Switch(config-if)#name vlan_10
Switch(config-if)#no shutdown
//Affecter des ports à un vlan :
Switch(config)#interface fa0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#no shutdown
//Création d’un port trunk :
Switch(config)#interface fa0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#no shutdown

Routeur :

//Accéder à la configuration :
Router>enable
Router#conf t
//Activation de l’interface physique :
Router(config)#interface fa0/0
Router(config)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
//Création d’une interface physique avec encapsulation :
Router(config)#interface fa0/0.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
//Configuration DHCP relais :
Router(config)#interface fa0/0.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#ip helper-address 192.168.1.2
Router(config-subif)#no shutdown
Router(config-subif)#exit

Was this article helpful?